收藏 [登录/注册] 欢迎
榕基门户网及子站
联系我们
  • 福建榕基软件股份有限公司
  • 电话:0591-87860988
  • 传真:0591-87869595
  • 地址:福建省福州市鼓楼区
  •    梅峰路
  •    6号
  • 邮编:350003
您的当前位置:首页 > 技术支持 > 漏洞公告

Linux kernel atyfb_ioctl函数信息泄露漏洞(CVE-2017-14156)

受影响系统:

Linux kernel <= 4.12.10

描述:CVE(CAN) ID: CVE-2017-14156

Linux Kernel是Linux操作系统的内核。

Linux kernel <= 4.12.10版本,drivers/video/fbdev/aty/atyfb_base.c/atyfb_ioctl函数未初始化某些数据结构,可使本地用户通过读取填充字节相关的位置,获取内核栈内存的信息。

<*来源:vendor
  *>

建议:厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/torvalds/linux/pull/441
https://marc.info/?l=linux-kernel&m=150401461613306&w=2
https://marc.info/?l=linux-kernel&m=150453196710422&w=2