收藏 [登录/注册] 欢迎
榕基门户网及子站
联系我们
  • 福建榕基软件股份有限公司
  • 电话:0591-87860988
  • 传真:0591-87869595
  • 地址:福建省福州市鼓楼区
  •    梅峰路
  •    6号
  • 邮编:350003
您的当前位置:首页 > 技术支持 > 漏洞公告

GoAhead websDecodeUrl空指针间接引用漏洞(CVE-2017-14149)

受影响系统:

GoAhead Software GoAhead WebServer 3.4.0-3.6.5

描述:CVE(CAN) ID: CVE-2017-14149

GoAhead是简单又安全的嵌入式网络服务器。

GoAhead 3.4.0-3.6.5版本,http.c/websDecodeUrl函数中存在空指针间接引用漏洞,攻击者通过构造的"POST / HTTP/1.1"请求,利用此漏洞,导致受影响应用崩溃。

<*来源:vendor
  *>

建议:厂商补丁:

GoAhead Software
----------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/shadow4u/goaheaddebug/blob/master/README.md