收藏 [登录/注册] 欢迎
榕基门户网及子站
联系我们
  • 福建榕基软件股份有限公司
  • 电话:0591-87860988
  • 传真:0591-87869595
  • 地址:福建省福州市鼓楼区
  •    梅峰路
  •    6号
  • 邮编:350003
您的当前位置:首页 > 技术支持 > 漏洞公告

Apache Hadoop信息泄露漏洞(CVE-2016-3086)

受影响系统:

    Apache Group Hadoop 2.7.x < 2.7.3
    Apache Group Hadoop 2.6.x < 2.6.5

描述:BUGTRAQ  ID: 95335
CVE(CAN) ID: CVE-2016-3086

Apache Hadoop是分布式系统基础架构。

Apache Hadoop 2.6.x < 2.6.5、2.7.x < 2.7.3版本,若用CredentialProvider功能加密NodeManager配置内的密码,YARN NodeManager所生成的任何容器都可以访问已经加密密码。

<*来源:Robert Kanter
  *>

建议:临时解决方法:

如果您不能立刻安装补丁或者升级,NSFOCUS建议您采取以下措施以降低威胁:

* 适当设置jceks文件以限制未授权用户访问。

厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://mail-archives.apache.org/mod_mbox/hadoop-general/201701.mbox/%3C0ed32746-5a53-9051-5877-2b1abd88beb6%40apache.org%3E