收藏 [登录/注册] 欢迎
榕基门户网及子站
联系我们
  • 福建榕基软件股份有限公司
  • 电话:0591-87860988
  • 传真:0591-87869595
  • 地址:福建省福州市鼓楼区
  •    软件大道89号
  •    A区15座
  • 邮编:350003
您的当前位置:首页 > 技术支持 > 漏洞公告

JasPer 'libjasper/jpc/jpc_math.c'拒绝服务漏洞(CVE-2018-9055)

受影响系统:
github JasPer 2.0.14
描述:
BUGTRAQ  ID: 103577
CVE(CAN) ID: CVE-2018-9055

JasPer包括了提供JPEG-2000 Part-1标准所定义的编码解码器的参考软件实现,用C语言编写。

JasPer 2.0.14版本在libjasper/jpc/jpc_math.c/jpc_firstone函数中存在安全漏洞,可使攻击者通过可达断言利用此漏洞造成拒绝服务。

<*来源:pwd @360teamserious
  *>

建议:
厂商补丁:

github
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/mdadams/jasper/issues/172
http://www.ece.uvic.ca/~mdadams/software.html
https://bugzilla.redhat.com/show_bug.cgi?id=1561699
https://access.redhat.com/security/cve/cve-2018-9055